# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)\s*\((.*?)\)|(.*)"
test_str = ("Aerospace Technologies of Australia Pty Ltd (Australia)\n"
"American Tactical Aircraft Consultants (United States)\n"
"ATEC vos (Czech Republic)\n"
"Aviation Technology Group Inc (United States)\n"
"Atlas Aircraft Corporation of South Africa (Pty) Ltd (South Africa)\n"
"GIE Avions de Transport Régional (France/Italy)\n"
"Auster Aircraft Ltd (United Kingdom)\n"
"Austflight ULA Pty Ltd (Australia)\n"
"Australian Aerospace Pty Ltd (Australia)\n"
"Australite Inc (United States)\n"
"AutoGyro Europe GmbH (Germany)\n"
"OOO Samoletstroitelynyi Kompaniya Avantazh (Russia)\n"
"AvCraft Aviation LLC (United States)\n"
"Aveko sro (Czech Republic)\n"
"Azionari Vercellese Industrie Aeronautiche (Italy)\n"
"Avia-Zavody Jirího Dimitrova (Czech Republic)\n"
"see AERFER and AERMACCHI")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.