#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\S\n]*(\d{1,3})\n\s*(\d{6,})[^\S\n]*\n\s*(\d{14})[^\S\n]*\n(.+)\n(.+)"
Local $sString = " تحميل ملف الطباعة تعليمات طباعـــة" & @CRLF & _
" 1 / 4 " & @CRLF & _
" " & @CRLF & _
"Main Report" & @CRLF & _
" " & @CRLF & _
" 25%" & @CRLF & _
" 50%" & @CRLF & _
" 75%" & @CRLF & _
" 100%" & @CRLF & _
" 125%" & @CRLF & _
" 150%" & @CRLF & _
" 200%" & @CRLF & _
" 300%" & @CRLF & _
" 400%" & @CRLF & _
" تقرير بيانات الطلاب الذين سددوا المصروفات الدراسية" & @CRLF & _
" عن طريق منافذ الدفع البنكي 2019-2020 " & @CRLF & _
"المديرية " & @CRLF & _
"المرحلة" & @CRLF & _
":" & @CRLF & _
":" & @CRLF & _
"الإدارة " & @CRLF & _
"التبعية" & @CRLF & _
":" & @CRLF & _
":" & @CRLF & _
"كود الطالب" & @CRLF & _
"جهة الدفع" & @CRLF & _
"رقم قومي الطالب" & @CRLF & _
"اسم الطالب" & @CRLF & _
"اعدادى" & @CRLF & _
"رسمى" & @CRLF & _
"اسم المدرسة" & @CRLF & _
":" & @CRLF & _
"م" & @CRLF & _
"مطروح" & @CRLF & _
"الحمام" & @CRLF & _
"اولاد مسعود الاعدادية المشتركة" & @CRLF & _
"الصف" & @CRLF & _
":" & @CRLF & _
"الصف الأول" & @CRLF & _
" 1" & @CRLF & _
" 458316219 " & @CRLF & _
" 30709101600371 " & @CRLF & _
"ابراهيم وليد ابراهيم ابوالحمد" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 2" & @CRLF & _
" 458361688 " & @CRLF & _
" 30702263300318 " & @CRLF & _
"احمد ابوالريش فرج عبدالله" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 3" & @CRLF & _
" 458312720 " & @CRLF & _
" 30703143300418 " & @CRLF & _
"اسلام فتحى محمد ناجى" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 4" & @CRLF & _
" 458790904 " & @CRLF & _
" 30606101802299 " & @CRLF & _
"اسلام نصار حسين نصار حسين عبد الونيس" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 5" & @CRLF & _
" 458312908 " & @CRLF & _
" 30612013300259 " & @CRLF & _
"ايمن راضى صالح سلومه" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 6" & @CRLF & _
" 458884564 " & @CRLF & _
" 30802203300186 " & @CRLF & _
"بسمه محمد ابراهيم ظدم" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 7" & @CRLF & _
" 477625786 " & @CRLF & _
" 30708263300235 " & @CRLF & _
"بشار نصر الله مصوف السايب" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 8" & @CRLF & _
" 458805339 " & @CRLF & _
" 30708203300708 " & @CRLF & _
"بشرى محمد عبدالناصر عبدالرؤوف رحمى" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 9" & @CRLF & _
" 458707736 " & @CRLF & _
" 30711103300663 " & @CRLF & _
"جنات منصور مسعود ابوسيف" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 10" & @CRLF & _
" 458884629 " & @CRLF & _
" 30801013303115 " & @CRLF & _
"حكيم عبدالقادر فرج قنديل" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 11" & @CRLF & _
" 464285926 " & @CRLF & _
" 30801121603028 " & @CRLF & _
"روان ابراهيم محمد محمد قطب" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 12" & @CRLF & _
" 459700550 " & @CRLF & _
" 30707150204055 " & @CRLF & _
"سعيد نوح قوية نصر" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 13" & @CRLF & _
" 458804725 " & @CRLF & _
" 30702253300379 " & @CRLF & _
"عبدالرحمن ابراهيم عبدالرؤوف رحمى" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 14" & @CRLF & _
" 457185700 " & @CRLF & _
" 30702013300096 " & @CRLF & _
"عبدالله حسين رضوان يونس" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 15" & @CRLF & _
" 458707614 " & @CRLF & _
" 30803083300515 " & @CRLF & _
"عبدالناصر خميس محمد عقيل" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 16" & @CRLF & _
" 458312757 " & @CRLF & _
" 30707113300427 " & @CRLF & _
"عبير على عبدالرؤف رحمى" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 17" & @CRLF & _
" 458361421 " & @CRLF & _
" 30711153300478 " & @CRLF & _
"على حامد راغب زايد" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 18" & @CRLF & _
" 446292331 " & @CRLF & _
" 30605243300073 " & @CRLF & _
"فارس عطيه عباس بسيس" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 19" & @CRLF & _
" 463507046 " & @CRLF & _
" 30608183300574 " & @CRLF & _
"فارس فرج شحات قنديل" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 20" & @CRLF & _
" 458810352 " & @CRLF & _
" 30701283300059 " & @CRLF & _
"كريم جبريل سليمان غالب" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 21" & @CRLF & _
" 467915100 " & @CRLF & _
" 30709161801074 " & @CRLF & _
"كريم عاطف عبدالباسط حجازى" & @CRLF & _
"منافذ فورى" & @CRLF & _
" 22" & @CRLF & _
" 458361712 " & @CRLF & _
" 30702263302396 " & @CRLF & _
"محمد ابوالريش فرج عبدالله" & @CRLF & _
"منافذ فورى" & @CRLF & _
"2020/06/12" & @CRLF & _
"Page 1 of 4" & @CRLF & _
"مسئول شئون الطلاب" & @CRLF & _
"خاتم " & @CRLF & _
"الشعار" & @CRLF & _
"مدير المدرسة" & @CRLF & _
" 2015© جميع الحقوق محفوظة لمركز معلومات -وزارة التربية والتعليم"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")