package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.+?)\s(.+?)$`)
var str = `2.2.1-rc1 20201010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}