$re = '/^(?:.+?)\s(.+?)$/m';
$str = '2.2.1-rc1 20201010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);