const regex = /(?:[^,]*,\s*){3}(?<test>\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^,]*,\\s*){3}(?<test>\\w+)', 'g')
const str = `12/11/2018 , abc , def , ced , xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}