use strict;
my $str = ';;;559.34;';
my $regex = qr/;;;\d+\K\.(?=[0-9]{2};)/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";