$re = '/;;;\d+\K\.(?=[0-9]{2};)/';
$str = ';;;559.34;';
$subst = ",";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;