package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(?:,[^,]*){2}$`)
var str = `suite 1, street 1, zip city, country`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}