const regex = /^(?=[^P]*(?:ParNew|P.*ParNew|PSYoungGen|DefNew)).*?(?P<ParNew_before_1>\d+)K->(?P<ParNew_after_1>\d+)K\((?P<young_heap_size>\d+)K\), (?P<par_new_duration>\d+\.\d+) secs\] (?P<ParNew_before_2>\d+)K\->(?P<ParNew_after_2>\d+)K\((?P<total_heap_size>\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^P]*(?:ParNew|P.*ParNew|PSYoungGen|DefNew)).*?(?P<ParNew_before_1>\\d+)K->(?P<ParNew_after_1>\\d+)K\\((?P<young_heap_size>\\d+)K\\), (?P<par_new_duration>\\d+\\.\\d+) secs\\] (?P<ParNew_before_2>\\d+)K\\->(?P<ParNew_after_2>\\d+)K\\((?P<total_heap_size>\\d+)', 'g')
const str = `146372.273: [GC146372.274: [ParNew: 378633K->88155K(419456K), 0.0313803 secs] 9893391K->9602913K(12478080K), 0.0320299 secs] [Times: user=0.32 sys=0.01, real=0.03 secs]
2017-05-12T10:35:46.076+0000: 2.799: [GC2017-05-12T10:35:46.076+0000: 2.800: [ParNew: 409024K->51072K(460096K), 0.3273966 secs] 409024K->121051K(2046080K), 0.3275292 secs] [Times: user=0.31 sys=0.07, real=0.33 secs]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}