#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\S+)\s+(\d{1,2}\.\d{1,2}\.\d{4}.*)((?:\r?\n(?![^\S\r\n]*\S+\s*\d{1,2}\.\d{1,2}\.).*)*)"
Local $sString = "Pondělí" & @CRLF & _
" 31.8.2020" & @CRLF & _
" " & @CRLF & _
" Každý všední den 11:00 - 15:00" & @CRLF & _
"" & @CRLF & _
" Polévka:" & @CRLF & _
" 0,25l Zeleninová polévka se smetanou (7,9)" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" " & @CRLF & _
" 0,25l Kapustová s klobásou " & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" 1150g Grilovaná kuřecí prsa s citronovým kuskusem se zeleninou (1,9)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 2150g Uzená kýta se smetanovou omáčkou s křenem, kynutý knedlík (1,3,7)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 3300g Strozzapreti se sýrovou omáčkou, ořechy a kousky kuřecích prs (1,3,7,8)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 4250g Cizrna na zelenině, curry koření, kokosovém mléce a koriandru s bulgurem s dýňovými semínky (1)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" Úterý" & @CRLF & _
" 1.9.2020" & @CRLF & _
" " & @CRLF & _
" Každý všední den 11:00 - 15:00" & @CRLF & _
"." & @CRLF & _
" Polévka:" & @CRLF & _
" 0,25l Bramborový krém s brynzou (7)" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" " & @CRLF & _
" 0,25l Slepičí vývar s masem, zeleninou a nudlemi (1,3,9)" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" 1150g Kuřecí steak se zeleninou na másle, bramborová kaše (7,9)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 2150g Hovězí tokáň s divokou rýží (12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 3300g Parmazánové risotto s karamelovou cibulí, kousky vepřové panenky, rukola (7)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 4150g Čočková sekaná s uzeným tofu, bramborová kaše se sójovým mlékem, okurek (1,3,6,12) " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" Středa" & @CRLF & _
" 2.9.2020" & @CRLF & _
" " & @CRLF & _
" Každý všední den 11:00 - 15:00" & @CRLF & _
"." & @CRLF & _
" Polévka:" & @CRLF & _
" 0,25l Hovězí vývar s masem, zeleninou a nudlemi (1,3,9)" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" " & @CRLF & _
" 0,25l Krém z dýně, mrkve a červeného kari s kokosovým mlékem" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" 1150g Burger s vepřovým trhaným masem v BBQ, coleslaw, čedar, hranolky (1,3,6,7,10,11,12,13)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 129,-" & @CRLF & _
" " & @CRLF & _
" 2150g Vepřová líčka na černém pivě a jablkách, šťouchaný brambor (1) " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 3300g Orecchiette s krůtím ragú na zelenině a rajčatech se sušenými houbami, parmazán (1,3,7,9)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 4250g Bramborový gratin s dýní, listový salát (3,7)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" Čtvrtek" & @CRLF & _
" 3.9.2020" & @CRLF & _
" " & @CRLF & _
" Každý všední den 11:00 - 15:00" & @CRLF & _
"." & @CRLF & _
" Polévka:" & @CRLF & _
" 0,25l Frankfurtská s párkem (7)" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" " & @CRLF & _
" 0,25l Hráškový krém s mátou (7)" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" 1150g Vepřová krkovice alla porchetta, šťouchaný brambor se zakysanou smetanou (7,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 2150g Kuřecí nudličky s uzenou paprikou, rajčaty a cizrnou, jasmínová rýže " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 3300g Spaghetti „Amatriciana“ (červená cibule, pancetta, tomatová om., česnek, chilli), parmazán (1,3,7)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 4250g Mexické černé fazole se zeleninou a kukuřicí, tortila, pikantní dip salsa verde (1,7,9)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" Pátek" & @CRLF & _
" 4.9.2020" & @CRLF & _
" " & @CRLF & _
" Každý všední den 11:00 - 15:00" & @CRLF & _
"." & @CRLF & _
" Polévka:" & @CRLF & _
" 0,25l Česneková se zeleninou a kroupami, uzené maso (1,9)" & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" " & @CRLF & _
" 0,25l Fenyklová " & @CRLF & _
" " & @CRLF & _
" 20,-" & @CRLF & _
" 1150g Smažený sýr se šunkou, vařené brambory, tatarská omáčka (1,3,7,10,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 2150g Dušený vepřový plátek s okurkou, vejcem a párkem, jasmínová rýže (3,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 3300g Penne s cuketovou omáčkou se slaninou, sušená rajčata, parmazán, polníček (1,3,7)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 109,-" & @CRLF & _
" " & @CRLF & _
" 4250g Šumavský toč (kynutá bramborová buchta), houbové soté (1,3,7)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 99,-" & @CRLF & _
" " & @CRLF & _
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-" & @CRLF & _
" " & @CRLF & _
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" 119,-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")