import re
regex = re.compile(r"(\S+)\s+(\d{1,2}\.\d{1,2}\.\d{4}.*)((?:\r?\n(?![^\S\r\n]*\S+\s*\d{1,2}\.\d{1,2}\.).*)*)", flags=re.MULTILINE)
test_str = ("Pondělí\n"
" 31.8.2020\n"
" \n"
" Každý všední den 11:00 - 15:00\n\n"
" Polévka:\n"
" 0,25l Zeleninová polévka se smetanou (7,9)\n"
" \n"
" 20,-\n"
" \n"
" 0,25l Kapustová s klobásou \n"
" \n"
" 20,-\n"
" 1150g Grilovaná kuřecí prsa s citronovým kuskusem se zeleninou (1,9)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 2150g Uzená kýta se smetanovou omáčkou s křenem, kynutý knedlík (1,3,7)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 3300g Strozzapreti se sýrovou omáčkou, ořechy a kousky kuřecích prs (1,3,7,8)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 4250g Cizrna na zelenině, curry koření, kokosovém mléce a koriandru s bulgurem s dýňovými semínky (1)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" Úterý\n"
" 1.9.2020\n"
" \n"
" Každý všední den 11:00 - 15:00\n"
".\n"
" Polévka:\n"
" 0,25l Bramborový krém s brynzou (7)\n"
" \n"
" 20,-\n"
" \n"
" 0,25l Slepičí vývar s masem, zeleninou a nudlemi (1,3,9)\n"
" \n"
" 20,-\n"
" 1150g Kuřecí steak se zeleninou na másle, bramborová kaše (7,9)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 2150g Hovězí tokáň s divokou rýží (12)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 3300g Parmazánové risotto s karamelovou cibulí, kousky vepřové panenky, rukola (7)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 4150g Čočková sekaná s uzeným tofu, bramborová kaše se sójovým mlékem, okurek (1,3,6,12) \n"
" \n"
" \n"
" 109,-\n"
" \n"
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" Středa\n"
" 2.9.2020\n"
" \n"
" Každý všední den 11:00 - 15:00\n"
".\n"
" Polévka:\n"
" 0,25l Hovězí vývar s masem, zeleninou a nudlemi (1,3,9)\n"
" \n"
" 20,-\n"
" \n"
" 0,25l Krém z dýně, mrkve a červeného kari s kokosovým mlékem\n"
" \n"
" 20,-\n"
" 1150g Burger s vepřovým trhaným masem v BBQ, coleslaw, čedar, hranolky (1,3,6,7,10,11,12,13)\n"
" \n"
" \n"
" 129,-\n"
" \n"
" 2150g Vepřová líčka na černém pivě a jablkách, šťouchaný brambor (1) \n"
" \n"
" \n"
" 109,-\n"
" \n"
" 3300g Orecchiette s krůtím ragú na zelenině a rajčatech se sušenými houbami, parmazán (1,3,7,9)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 4250g Bramborový gratin s dýní, listový salát (3,7)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" Čtvrtek\n"
" 3.9.2020\n"
" \n"
" Každý všední den 11:00 - 15:00\n"
".\n"
" Polévka:\n"
" 0,25l Frankfurtská s párkem (7)\n"
" \n"
" 20,-\n"
" \n"
" 0,25l Hráškový krém s mátou (7)\n"
" \n"
" 20,-\n"
" 1150g Vepřová krkovice alla porchetta, šťouchaný brambor se zakysanou smetanou (7,12)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 2150g Kuřecí nudličky s uzenou paprikou, rajčaty a cizrnou, jasmínová rýže \n"
" \n"
" \n"
" 99,-\n"
" \n"
" 3300g Spaghetti „Amatriciana“ (červená cibule, pancetta, tomatová om., česnek, chilli), parmazán (1,3,7)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 4250g Mexické černé fazole se zeleninou a kukuřicí, tortila, pikantní dip salsa verde (1,7,9)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" Pátek\n"
" 4.9.2020\n"
" \n"
" Každý všední den 11:00 - 15:00\n"
".\n"
" Polévka:\n"
" 0,25l Česneková se zeleninou a kroupami, uzené maso (1,9)\n"
" \n"
" 20,-\n"
" \n"
" 0,25l Fenyklová \n"
" \n"
" 20,-\n"
" 1150g Smažený sýr se šunkou, vařené brambory, tatarská omáčka (1,3,7,10,12)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 2150g Dušený vepřový plátek s okurkou, vejcem a párkem, jasmínová rýže (3,12)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 3300g Penne s cuketovou omáčkou se slaninou, sušená rajčata, parmazán, polníček (1,3,7)\n"
" \n"
" \n"
" 109,-\n"
" \n"
" 4250g Šumavský toč (kynutá bramborová buchta), houbové soté (1,3,7)\n"
" \n"
" \n"
" 99,-\n"
" \n"
" 5250g Hot dog s vídeňskými párky, fazolový salát, hořčicová majonéza, rukola, hranolky (1,3,10)\n"
" \n"
" \n"
" 119,-\n"
" \n"
" 6250g Listový salát s okurkem, rajčetem, barevnou paprikou, do růžova grilovanou vepřovou panenkou, hořčično-medový dresing (10,12)\n"
" \n"
" \n"
" 119,-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")