using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@when\(((?:[^()]*(?:(\((?:[^()]+|(?2))*+\)))?)*+)\)";
string input = @"@when('foo')
@when(function('foo'))
@when(function(['foo' => 'bar']))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}