use strict;
my $str = '(4) The Governor-General may arrange\\n with the Chief Minister of the Australian Capital Territory for the variation or revocation of an \\n\\narrangement in force under subsection (3). \\nNorthern Territory \\n (5) The Governor-General may make arrangements with the \\nAdministrator of the Northern \\nTerritory with respect to the';
my $regex = qr/(?<=(\(\d\)|\d\.\d))(.(?!\(\d\)|\d\.\d))*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}