re = /(?<=(\(\d\)|\d\.\d))(.(?!\(\d\)|\d\.\d))*/
str = '(4) The Governor-General may arrange\\n with the Chief Minister of the Australian Capital Territory for the variation or revocation of an \\n\\narrangement in force under subsection (3). \\nNorthern Territory \\n (5) The Governor-General may make arrangements with the \\nAdministrator of the Northern \\nTerritory with respect to the'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end