package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b|\s)(-{3})(\b|\s)`)
var str = `This- -is - a test-sentence. -Test- --- One-Two--Three---Four----.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}