re = /(\b|\s)(-{3})(\b|\s)/
str = 'This- -is - a test-sentence. -Test- --- One-Two--Three---Four----.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end