package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Case Lead ID: #(.+)`)
var str = ` Wed, September 7th, 11:06am - Case Lead ID: #260-A53-0C4C
John Doe | johndoe@gmail.com | 123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}