$re = '/Case Lead ID: #(.+)/m';
$str = ' Wed, September 7th, 11:06am - Case Lead ID: #260-A53-0C4C
John Doe | johndoe@gmail.com | 123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);