#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(\$[0-9]{1,3}\.[0-9]{1,2})(?<Text>.*?)(\$[0-9]{1,3}\.[0-9]{1,2})"
Local $sString = "$12.33" & @CRLF & _
"1" & @CRLF & _
"0000" & @CRLF & _
"0000" & @CRLF & _
"Some Text1" & @CRLF & _
"some Text1" & @CRLF & _
"$0.00" & @CRLF & _
"123A" & @CRLF & _
"Some Text 2" & @CRLF & _
"$12.34" & @CRLF & _
"000" & @CRLF & _
"Some Text 3" & @CRLF & _
"$90.33"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")