$re = '/(\$[0-9]{1,3}\.[0-9]{1,2})(?<Text>.*?)(\$[0-9]{1,3}\.[0-9]{1,2})/is';
$str = '$12.33
1
0000
0000
Some Text1
some Text1
$0.00
123A
Some Text 2
$12.34
000
Some Text 3
$90.33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);