const regex = /([\u0600-\u06FF]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\u0600-\\u06FF]+)', 'gm')
const str = `Blah العَرَبِيَّة blah, I am sorry I can't speak Arabic so I posted few random العَرَبِيَّة words.
I can do ٠٧٢٤٦٦٦٦٦ numbers as well.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}