$re = '/([\u0600-\u06FF]+)/m';
$str = 'Blah العَرَبِيَّة blah, I am sorry I can\'t speak Arabic so I posted few random العَرَبِيَّة words.
I can do ٠٧٢٤٦٦٦٦٦ numbers as well.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);