package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[A-ZА-ЯЁ]+`)
var str = `Разбить строку на подстроки по разделителю с использованием foreach`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}