$re = '/[A-ZА-ЯЁ]+/i';
$str = 'Разбить строку на подстроки по разделителю с использованием foreach';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);