#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/([a-zA-Z]{2}-[a-zA-Z]{2})\/cms\/api\/preview([a-zA-Z0-9-_=\/]*)(.*?)(?(3)([a-zA-Z0-9-_=&#]*)|)$"
Local $sString = "/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui#user=Artibani" & @CRLF & _
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123" & @CRLF & _
"/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/paperoga?qui=qua&quo=qui&cap-paperopoli=12345" & @CRLF & _
"/en-US/cms/api/preview/pippo/pluto23?qua=qui" & @CRLF & _
"/en-US/cms/api/preview/pippo-clarabella/EN-us/123???" & @CRLF & _
"/en-US/cms/api/preview/pippo/pluto-orazio?" & @CRLF & _
"/en-US/cms/api/preview/pippo/pico-archimede/" & @CRLF & _
"/en-US/cms/api/preview/pippo/pico/archimede" & @CRLF & _
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user=Faraci" & @CRLF & _
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#user=Faraci" & @CRLF & _
"/en-US/cms/api/preview" & @CRLF & _
"/en-US/cms/api/preview/" & @CRLF & _
"/en-US/cms/api/preview?" & @CRLF & _
"/en-US/cms/api/preview/?" & @CRLF & _
"/en-US/cms/api/preview?qui=qua&quo=qui#user=Artibani" & @CRLF & _
"/en-US/cms/api/preview/?qui=qua&quo=qui#user=Artibani" & @CRLF & _
"" & @CRLF & _
"/en-US/cms/api/preview#user=Faraci" & @CRLF & _
"/en-US/cms/api/preview/#user=Faraci" & @CRLF & _
"/en-US/cms/api/preview?#user=Faraci" & @CRLF & _
"/en-US/cms/api/preview/?#user=Faraci" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Output for Nginx:" & @CRLF & _
"/preview/$2?lang=$1&$4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")