const regex = /^\/([a-zA-Z]{2}-[a-zA-Z]{2})\/cms\/api\/preview([a-zA-Z0-9-_=\/]*)(.*?)(?(3)([a-zA-Z0-9-_=&#]*)|)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/([a-zA-Z]{2}-[a-zA-Z]{2})\\\/cms\\\/api\\\/preview([a-zA-Z0-9-_=\\\/]*)(.*?)(?(3)([a-zA-Z0-9-_=&#]*)|)$', 'mg')
const str = `/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui#user=Artibani
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui&cap_paperopoli=123
/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/paperoga?qui=qua&quo=qui&cap-paperopoli=12345
/en-US/cms/api/preview/pippo/pluto23?qua=qui
/en-US/cms/api/preview/pippo-clarabella/EN-us/123???
/en-US/cms/api/preview/pippo/pluto-orazio?
/en-US/cms/api/preview/pippo/pico-archimede/
/en-US/cms/api/preview/pippo/pico/archimede
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user=Faraci
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#user=Faraci
/en-US/cms/api/preview
/en-US/cms/api/preview/
/en-US/cms/api/preview?
/en-US/cms/api/preview/?
/en-US/cms/api/preview?qui=qua&quo=qui#user=Artibani
/en-US/cms/api/preview/?qui=qua&quo=qui#user=Artibani
/en-US/cms/api/preview#user=Faraci
/en-US/cms/api/preview/#user=Faraci
/en-US/cms/api/preview?#user=Faraci
/en-US/cms/api/preview/?#user=Faraci
Output for Nginx:
/preview/\$2?lang=\$1&\$4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}