using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([1][0]\d{2})";
string input = @"1000
1001
1002
1003
1004
1099
1210";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}