package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[cC][aA][nN].{10}$`)
var str = `CAN123abcfg1s
can7hgcghat12
Can61hj78gab1h7w`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}