$re = '/^[cC][aA][nN].{10}$/m';
$str = 'CAN123abcfg1s
can7hgcghat12
Can61hj78gab1h7w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);