re = /^([A-Z]{2,3}[0-9]{2}[A-Z0-9]{1,4}[0-9]{1,4})|([A-Z]{2}[0-9]{3})|([A-Z]{2}[0-9]{2}[A-Z]{1}[0-9]{1,4})/m
str = 'AB12BS230000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end