// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Z]{2,3}[0-9]{2}[A-Z0-9]{1,4}[0-9]{1,4})|([A-Z]{2}[0-9]{3})|([A-Z]{2}[0-9]{2}[A-Z]{1}[0-9]{1,4})").unwrap();
let string = "AB12BS230000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}