package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]{0,1}|\s\w`)
var str = `john smit richart de la cruz silva`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}