$re = '/^[a-z]{0,1}|\s\w/m';
$str = 'john smit richart de la cruz silva';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);