package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[^-a-z]\d{0,}(([.]{1})?\d?){0,}$`)
var str = `jcucw 12 iwriu 8.88`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}