$re = '/^[^-a-z]\d{0,}(([.]{1})?\d?){0,}$/mi';
$str = 'jcucw 12 iwriu 8.88';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);