#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\s)*<task action="4" id="94(\d\d\d)00(\d\d)">(?:\s)*<release>(?:\s)*<item type="cost" vitality="\d"(?:\s)*\/>((?:\n|.)*?)<item type="param(?:(?:\n|.)*?)(?=<\/win)((?:\n|.)*?)<\/release>(?:\s)*<\/task>(?:\s)*"
Local $sString = " <task action="4" id="941010010">" & @CRLF & _
" <release>" & @CRLF & _
" <item type="cost" vitality="1" />" & @CRLF & _
" <item type="fight" npcid="1010010">" & @CRLF & _
" <win>" & @CRLF & _
" <item type="aside" content="[color=#ff7e53]你胜利了![/color]" auto="true" />" & @CRLF & _
" <item type="random">" & @CRLF & _
" <item probability="0.001">" & @CRLF & _
" <item type="reward" yueli="300" money="100" auto="true">" & @CRLF & _
" <item id="2801" num="1" />" & @CRLF & _
" </item>" & @CRLF & _
" </item>" & @CRLF & _
" <item probability="0.001">" & @CRLF & _
" <item type="reward" yueli="300" money="100" auto="true">" & @CRLF & _
" <item id="2901" num="1" />" & @CRLF & _
" </item>" & @CRLF & _
" </item>" & @CRLF & _
" <item probability="0.001">" & @CRLF & _
" <item type="reward" yueli="300" money="100" auto="true">" & @CRLF & _
" <item id="3001" num="1" />" & @CRLF & _
" </item>" & @CRLF & _
" </item>" & @CRLF & _
" <item probability="0.001">" & @CRLF & _
" <item type="reward" yueli="300" money="100" auto="true">" & @CRLF & _
" <item id="3101" num="1" />" & @CRLF & _
" </item>" & @CRLF & _
" </item>" & @CRLF & _
" </item>" & @CRLF & _
" <item type="param" key="fight-1010010" action="update" value="1" />" & @CRLF & _
" </win>" & @CRLF & _
" <lose>" & @CRLF & _
" <item type="aside" content="[color=#ff7e53]你被{rnpc}打倒在地![/color]" auto="true" />" & @CRLF & _
" </lose>" & @CRLF & _
" </item>" & @CRLF & _
" </release>" & @CRLF & _
" </task>"
Local $sSubst = "\n\n\n\n<stroy id="$17$2" areaid="0" startid="-1" endid="-1" maxnum='0' interval='0' count="0" type='3'>$3$4</stroy>\n\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)