# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s)*<task action=\"4\" id=\"94(\d\d\d)00(\d\d)\">(?:\s)*<release>(?:\s)*<item type=\"cost\" vitality=\"\d\"(?:\s)*\/>((?:\n|.)*?)<item type=\"param(?:(?:\n|.)*?)(?=<\/win)((?:\n|.)*?)<\/release>(?:\s)*<\/task>(?:\s)*"
test_str = (" <task action=\"4\" id=\"941010010\">\n"
" <release>\n"
" <item type=\"cost\" vitality=\"1\" />\n"
" <item type=\"fight\" npcid=\"1010010\">\n"
" <win>\n"
" <item type=\"aside\" content=\"[color=#ff7e53]你胜利了![/color]\" auto=\"true\" />\n"
" <item type=\"random\">\n"
" <item probability=\"0.001\">\n"
" <item type=\"reward\" yueli=\"300\" money=\"100\" auto=\"true\">\n"
" <item id=\"2801\" num=\"1\" />\n"
" </item>\n"
" </item>\n"
" <item probability=\"0.001\">\n"
" <item type=\"reward\" yueli=\"300\" money=\"100\" auto=\"true\">\n"
" <item id=\"2901\" num=\"1\" />\n"
" </item>\n"
" </item>\n"
" <item probability=\"0.001\">\n"
" <item type=\"reward\" yueli=\"300\" money=\"100\" auto=\"true\">\n"
" <item id=\"3001\" num=\"1\" />\n"
" </item>\n"
" </item>\n"
" <item probability=\"0.001\">\n"
" <item type=\"reward\" yueli=\"300\" money=\"100\" auto=\"true\">\n"
" <item id=\"3101\" num=\"1\" />\n"
" </item>\n"
" </item>\n"
" </item>\n"
" <item type=\"param\" key=\"fight-1010010\" action=\"update\" value=\"1\" />\n"
" </win>\n"
" <lose>\n"
" <item type=\"aside\" content=\"[color=#ff7e53]你被{rnpc}打倒在地![/color]\" auto=\"true\" />\n"
" </lose>\n"
" </item>\n"
" </release>\n"
" </task>")
subst = "\\n\\n\\n\\n<stroy id=\"$17$2\" areaid=\"0\" startid=\"-1\" endid=\"-1\" maxnum='0' interval='0' count=\"0\" type='3'>$3$4</stroy>\\n\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.