#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(restaur*|bar|brasserie|\sbouches?\s)"
Local $sString = "[activités idéales]" & @CRLF & _
"activités idéales : opticien lunetier, restauration rapide" & @CRLF & _
"" & @CRLF & _
"[IDEALMENT DEDIE]" & @CRLF & _
"idéalement destiné à une activités de restauration" & @CRLF & _
"idéalement à une belle enseigne de pizzeria franchisée" & @CRLF & _
"idéalement pensé pour une activité de restauration" & @CRLF & _
"idéalement être transformée en restaurant" & @CRLF & _
"idéalement dédiée à la restauration" & @CRLF & _
"" & @CRLF & _
"[IDEAL POUR]" & @CRLF & _
"idéal pour un restaurant" & @CRLF & _
"idéal pour des commerces de proximité et/ou de bouches" & @CRLF & _
"déal pour toutes activités de restauration" & @CRLF & _
"idéal pour la restauration" & @CRLF & _
"idéal pour de la restauration avec ou sans nuisances" & @CRLF & _
"idéal pour un bar" & @CRLF & _
"" & @CRLF & _
"[usage de ..]" & @CRLF & _
"usage de brasserie" & @CRLF & _
"usage de restauration" & @CRLF & _
"" & @CRLF & _
"[LOCAL A USAGE DE..]" & @CRLF & _
"local à usage de supérette alimentaire" & @CRLF & _
"local à usage de restauration" & @CRLF & _
"" & @CRLF & _
"[AUTRES]" & @CRLF & _
"restaurant de plus de x couverts?" & @CRLF & _
"restaurant de x couverts" & @CRLF & _
"pour de la restauration" & @CRLF & _
"ideal petite restauration" & @CRLF & _
"usage de restauration" & @CRLF & _
"possibilité : restaurant" & @CRLF & _
"possibilité de restauration" & @CRLF & _
"restauration éventuelle" & @CRLF & _
"dédié à la restauration" & @CRLF & _
"à destination de restauration" & @CRLF & _
"activités comme restaurant" & @CRLF & _
"activités comme restauration" & @CRLF & _
"un bâtiment restauration" & @CRLF & _
"restauration autorisé" & @CRLF & _
"restauration sans nuisance" & @CRLF & _
"restauration froide ou sans nuisance" & @CRLF & _
"restauration rapide ou alimentaire" & @CRLF & _
"restaurant avec conduit de cheminée" & @CRLF & _
"la restauration est possible" & @CRLF & _
"restaurant avec une très belle visibilité" & @CRLF & _
"restaurant en angle" & @CRLF & _
"ce restaurant " & @CRLF & _
"ce joli restaurant" & @CRLF & _
"commerce de restauration" & @CRLF & _
"(un|ce) restaurant dispose" & @CRLF & _
"propose (un|ce) restaurant" & @CRLF & _
"restaurant avec licence" & @CRLF & _
"(une|cette) restauration rapide/snack" & @CRLF & _
"(un|ce) restaurant rapide " & @CRLF & _
"y compris restauration" & @CRLF & _
"un restaurant avec hotte à charbon" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")