import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(restaur*|bar|brasserie|\\sbouches?\\s)";
final String string = "[activités idéales]\n"
+ "activités idéales : opticien lunetier, restauration rapide\n\n"
+ "[IDEALMENT DEDIE]\n"
+ "idéalement destiné à une activités de restauration\n"
+ "idéalement à une belle enseigne de pizzeria franchisée\n"
+ "idéalement pensé pour une activité de restauration\n"
+ "idéalement être transformée en restaurant\n"
+ "idéalement dédiée à la restauration\n\n"
+ "[IDEAL POUR]\n"
+ "idéal pour un restaurant\n"
+ "idéal pour des commerces de proximité et/ou de bouches\n"
+ "déal pour toutes activités de restauration\n"
+ "idéal pour la restauration\n"
+ "idéal pour de la restauration avec ou sans nuisances\n"
+ "idéal pour un bar\n\n"
+ "[usage de ..]\n"
+ "usage de brasserie\n"
+ "usage de restauration\n\n"
+ "[LOCAL A USAGE DE..]\n"
+ "local à usage de supérette alimentaire\n"
+ "local à usage de restauration\n\n"
+ "[AUTRES]\n"
+ "restaurant de plus de x couverts?\n"
+ "restaurant de x couverts\n"
+ "pour de la restauration\n"
+ "ideal petite restauration\n"
+ "usage de restauration\n"
+ "possibilité : restaurant\n"
+ "possibilité de restauration\n"
+ "restauration éventuelle\n"
+ "dédié à la restauration\n"
+ "à destination de restauration\n"
+ "activités comme restaurant\n"
+ "activités comme restauration\n"
+ "un bâtiment restauration\n"
+ "restauration autorisé\n"
+ "restauration sans nuisance\n"
+ "restauration froide ou sans nuisance\n"
+ "restauration rapide ou alimentaire\n"
+ "restaurant avec conduit de cheminée\n"
+ "la restauration est possible\n"
+ "restaurant avec une très belle visibilité\n"
+ "restaurant en angle\n"
+ "ce restaurant \n"
+ "ce joli restaurant\n"
+ "commerce de restauration\n"
+ "(un|ce) restaurant dispose\n"
+ "propose (un|ce) restaurant\n"
+ "restaurant avec licence\n"
+ "(une|cette) restauration rapide/snack\n"
+ "(un|ce) restaurant rapide \n"
+ "y compris restauration\n"
+ "un restaurant avec hotte à charbon\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}