package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(\d{3}).*`)
var str = `I have 100 friends and 1 evil`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}