$re = '/.*?(\d{3}).*/m';
$str = 'I have 100 friends and 1 evil';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);