package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.\d+)?[KkMm]?$`)
var str = `400K
4.2.K
4.3K
3.2M
300000
4....K`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}