$re = '/^\d+(?:\.\d+)?[KkMm]?$/m';
$str = '400K
4.2.K
4.3K
3.2M
300000
4....K';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);