package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(([\da-z])\)`)
var str = `Lorem ipsum dolor sit amet,
(1)consectetur adipiscing elit, sed do eiusmod tempor incididunt
(2)ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip
(a) ex ea (commodo consequat). Duis aute irure dolor in (reprehenderit) in voluptate velit esse cillum dolore eu
(b) fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.`
var substitution = "\1. "
fmt.Println(re.ReplaceAllString(str, substitution))
}