// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\(([\da-z])\)").unwrap();
let string = "Lorem ipsum dolor sit amet,
(1)consectetur adipiscing elit, sed do eiusmod tempor incididunt
(2)ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip
(a) ex ea (commodo consequat). Duis aute irure dolor in (reprehenderit) in voluptate velit esse cillum dolore eu
(b) fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.";
let substitution = "\\1. ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}