package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+?7|8)([()\-\s]*\d[()\-\s]*){10}$`)
var str = `+7 (800) 555-35 35`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}