$re = '/^(\+?7|8)([()\-\s]*\d[()\-\s]*){10}$/m';
$str = '+7 (800) 555-35 35';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);