$re = '@/assets(/[^\s/?&#]+)+@m';
$str = '
-1
down vote
favorite
I need to search thru a sql file and find the filename (the end of the url) where the url contains /assets/
Example url:
https://www.example.com/assets/screenshots/this-is-an-example/2016-12-20_15-42-29.png
It has /assets/ in it, so I want to get the last part of the url, being:
2016-12-20_15-42-29.png
Another example:
https://www.example.com/images/screenshots/this-is-an-example/2016-12-20_15-42-29.png
Nothing would return because /assets/ was not found.
*The number of directories deep it goes will be different, so it could be /assets/dir1/dir2/filename.jpg, and the next could be /assets/dir1/dir2/dir3/dir4/filename.jpg
Hoping this can be accomplished using regular expression';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);