import Foundation
let pattern = ##"/assets(/[^\s/?&#]+)+"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-1
down vote
favorite
I need to search thru a sql file and find the filename (the end of the url) where the url contains /assets/
Example url:
https://www.example.com/assets/screenshots/this-is-an-example/2016-12-20_15-42-29.png
It has /assets/ in it, so I want to get the last part of the url, being:
2016-12-20_15-42-29.png
Another example:
https://www.example.com/images/screenshots/this-is-an-example/2016-12-20_15-42-29.png
Nothing would return because /assets/ was not found.
*The number of directories deep it goes will be different, so it could be /assets/dir1/dir2/filename.jpg, and the next could be /assets/dir1/dir2/dir3/dir4/filename.jpg
Hoping this can be accomplished using regular expression
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)