const regex = /^(1\s{0,1}\-{0,1}((\(\d{3}\))|(\d{3}))|((\(\d{3}\))|(\d{3})))\s{0,1}\-{0,1}\d{3}\s{0,1}\-{0,1}\d{4}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1\\s{0,1}\\-{0,1}((\\(\\d{3}\\))|(\\d{3}))|((\\(\\d{3}\\))|(\\d{3})))\\s{0,1}\\-{0,1}\\d{3}\\s{0,1}\\-{0,1}\\d{4}$', 'gmi')
const str = `1 555-555-5555
1 (555) 555-5555
5555555555
555-555-5555`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);